weird colour problem.

Testing area for the DBB members and staff!
Post Reply
User avatar
roid
DBB Master
DBB Master
Posts: 9982
Joined: Sun Dec 09, 2001 3:01 am
Location: Brisbane, Australia
Contact:

weird colour problem.

Post by roid » Sat Apr 28, 2012 4:35 am

why is this text green. But this text isn't?

Code: Select all

[color=green][b][u]why is this text green.[/b][/u]  But this text isn't?[/color]

Yet if i swap the order of the </b></u> around it works as it should:
this text is green and so is this

Code: Select all

[color=green][b][u]this text is green yay[/u][/b]  And so is this text![/color]
apparently we can't overlap different text formatting? that's pretty stupid


edit: This is on Chrome ver 18.0.1025.162 m
User avatar
CDN_Merlin
DBB_Master
DBB_Master
Posts: 9486
Joined: Thu Nov 05, 1998 12:01 pm
Location: Capital Of Canada

Re: weird colour problem.

Post by CDN_Merlin » Sat Apr 28, 2012 6:39 am

On my screen, both those texts are green. The first one looks a tad thicker.
Beta tested:
Game Stock Car 2012, Diablo 3, Descent 3 1.5 Patch, C&C Generals, Independance War 2, Starfleet Command 2, Settlers IV,Tzar, Allegiance, Starfleet Command, MAX 2, Defiance
ASUS Z170-P, Core I7-6700K, Coolermaster Hyper 212 EVO CPU Cooler, Gigabyte GF GTX970 OC 4GB GDDR5,Crucial 16GB 2133MHz DDR4, Samsung 850 EVO 250GB 2.5" SATA3 SSD, WD Black 1 TB, ASUS DVD Burner, ASUS 27" Monitor, Fractal Design R5 Mid-Tower Case, Thermaltake ToughPower Gold 750 Watt, Win 10 64Bit
User avatar
roid
DBB Master
DBB Master
Posts: 9982
Joined: Sun Dec 09, 2001 3:01 am
Location: Brisbane, Australia
Contact:

Re: weird colour problem.

Post by roid » Sat Apr 28, 2012 8:15 am

where it says "But this text isn't?", that original text was green too? woaaa.
might be a browser thing, what browser u using? (i'm using chrome)
User avatar
CDN_Merlin
DBB_Master
DBB_Master
Posts: 9486
Joined: Thu Nov 05, 1998 12:01 pm
Location: Capital Of Canada

Re: weird colour problem.

Post by CDN_Merlin » Sat Apr 28, 2012 8:19 am

I'm using firefox.
Beta tested:
Game Stock Car 2012, Diablo 3, Descent 3 1.5 Patch, C&C Generals, Independance War 2, Starfleet Command 2, Settlers IV,Tzar, Allegiance, Starfleet Command, MAX 2, Defiance
ASUS Z170-P, Core I7-6700K, Coolermaster Hyper 212 EVO CPU Cooler, Gigabyte GF GTX970 OC 4GB GDDR5,Crucial 16GB 2133MHz DDR4, Samsung 850 EVO 250GB 2.5" SATA3 SSD, WD Black 1 TB, ASUS DVD Burner, ASUS 27" Monitor, Fractal Design R5 Mid-Tower Case, Thermaltake ToughPower Gold 750 Watt, Win 10 64Bit
User avatar
roid
DBB Master
DBB Master
Posts: 9982
Joined: Sun Dec 09, 2001 3:01 am
Location: Brisbane, Australia
Contact:

Re: weird colour problem.

Post by roid » Sat Apr 28, 2012 8:34 am

fuckyoucoloursyoufuckingcolours.png
fuckyoucoloursyoufuckingcolours.png (24.59 KiB) Viewed 2945 times
dfgsdfg
User avatar
CDN_Merlin
DBB_Master
DBB_Master
Posts: 9486
Joined: Thu Nov 05, 1998 12:01 pm
Location: Capital Of Canada

Re: weird colour problem.

Post by CDN_Merlin » Sat Apr 28, 2012 9:20 am

The picture you just posted is what you say it is. Text is green and blue but the original post is all green
Beta tested:
Game Stock Car 2012, Diablo 3, Descent 3 1.5 Patch, C&C Generals, Independance War 2, Starfleet Command 2, Settlers IV,Tzar, Allegiance, Starfleet Command, MAX 2, Defiance
ASUS Z170-P, Core I7-6700K, Coolermaster Hyper 212 EVO CPU Cooler, Gigabyte GF GTX970 OC 4GB GDDR5,Crucial 16GB 2133MHz DDR4, Samsung 850 EVO 250GB 2.5" SATA3 SSD, WD Black 1 TB, ASUS DVD Burner, ASUS 27" Monitor, Fractal Design R5 Mid-Tower Case, Thermaltake ToughPower Gold 750 Watt, Win 10 64Bit
User avatar
roid
DBB Master
DBB Master
Posts: 9982
Joined: Sun Dec 09, 2001 3:01 am
Location: Brisbane, Australia
Contact:

Re: weird colour problem.

Post by roid » Sat Apr 28, 2012 10:22 am

:O
User avatar
Jeff250
DBB Master
DBB Master
Posts: 6387
Joined: Sun Sep 05, 1999 2:01 am
Location: ☃☃☃

Re: weird colour problem.

Post by Jeff250 » Sat Apr 28, 2012 1:30 pm

roid wrote:why is this text green. But this text isn't?

Code: Select all

[color=green][b][u]why is this text green.[/b][/u]  But this text isn't?[/color]
You need to close the BB tags in the opposite order as you opened them, just like with html.
User avatar
fliptw
DBB DemiGod
DBB DemiGod
Posts: 6415
Joined: Sat Oct 24, 1998 2:01 am
Location: Calgary Alberta Canada

Re: weird colour problem.

Post by fliptw » Wed May 02, 2012 1:56 pm

Jeff250 wrote:
roid wrote:why is this text green. But this text isn't?

Code: Select all

[color=green][b][u]why is this text green.[/b][/u]  But this text isn't?[/color]
You need to close the BB tags in the opposite order as you opened them, just like with html.
Well, html strict.

the reason is the bb parser isn't too good.
User avatar
Jeff250
DBB Master
DBB Master
Posts: 6387
Joined: Sun Sep 05, 1999 2:01 am
Location: ☃☃☃

Re: weird colour problem.

Post by Jeff250 » Wed May 02, 2012 3:18 pm

You can omit closing some HTML tags, but closing them in the wrong order is always invalid.
User avatar
fliptw
DBB DemiGod
DBB DemiGod
Posts: 6415
Joined: Sat Oct 24, 1998 2:01 am
Location: Calgary Alberta Canada

Re: weird colour problem.

Post by fliptw » Wed May 02, 2012 7:09 pm

the parser is bad because it a bit of an over-achiever. if all it did was simple replacement, then this thread would not need to exist, because it would've be displayed the way roid intended.
Post Reply